Install complete but first web access hits "HTTP Error 500.19"

paul.d.ruby's Avatar

paul.d.ruby

24 Jun, 2016 05:53 PM

I found this other discussion and have ensured the application pool is .NET V4.0.
http://support.hglabhq.com/discussions/problems/416-http-error-50019-systemruntimecaching

Screen shot of the error attached as hglabSetupError.PNG

The HgLabApplication Pool is set to .Net V4.0 as see in HgLabApplicationPool.PNG.

I have no idea what to do next.

Thanks,
Paul

  1. 1 Posted by paul.d.ruby on 24 Jun, 2016 05:57 PM

    paul.d.ruby's Avatar

    If I attempt to look at handler mappings from within IIS, I get more info on the failure but I don't understand what it means. See attachement...

  2. 2 Posted by paul.d.ruby on 24 Jun, 2016 06:23 PM

    paul.d.ruby's Avatar

    My previous attachments don't seem to be there so reattaching.

  3. paul.d.ruby closed this discussion on 27 Jun, 2016 06:33 PM.

  4. paul.d.ruby re-opened this discussion on 27 Jun, 2016 06:34 PM

  5. 3 Posted by paul.d.ruby on 27 Jun, 2016 06:34 PM

    paul.d.ruby's Avatar

    This was related to my IIS server configuration not allowing CGI. I'm beyond these issues now and struggling instead with SSL configuration, which has me stumped.

  6. paul.d.ruby closed this discussion on 27 Jun, 2016 06:35 PM.

  7. Anton Gogolev re-opened this discussion on 28 Jun, 2016 07:34 AM

  8. Support Staff 4 Posted by Anton Gogolev on 28 Jun, 2016 07:34 AM

    Anton Gogolev's Avatar

    Paul,

    What are your SSL issues?

  9. 5 Posted by paul.d.ruby on 28 Jun, 2016 01:38 PM

    paul.d.ruby's Avatar

    I wasn’t running IE as administrator, so that problem is fixed. But I have another question. Do we have anyone who knows how to use SSL with IIS for a mercurial server? I spent several hours yesterday trying to get it to work but I have no idea how to get IIS+SSL working. At the moment, I have it setup to use windows domain authentication but would rather use https. I don’t even know who to ask about it.

    Thanks,
    Paul

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

18 Feb, 2019 09:20 AM
26 Nov, 2018 01:47 PM
16 Nov, 2018 07:51 PM
06 Nov, 2018 04:30 PM
24 Oct, 2018 07:57 AM

 

20 Jul, 2018 11:07 PM
05 Jul, 2018 10:53 AM
27 May, 2018 01:33 AM
14 May, 2018 03:38 PM
04 May, 2018 07:45 AM
28 Feb, 2018 07:08 AM