does not appear to be an hg repository (HGLabs 1.10.6 and Mercurial 4.0.1)

Jesper's Avatar

Jesper

18 Jan, 2017 03:25 PM

Hey there.
I've run into an issue with pulling, cloning, pushing etc. using:
HGLabs 1.10.6 and Mercurial 4.0.1 (serverside) and
Mercurial 3.9.0 up untill version 4.0.1 (clientside)

It works with Mercurial 3.8.4 (Clientside) - but we have clients on a newer version (4.0.1), which we can't downgrade.

An issue a bit like this guy, in terms of "does not appear to be an hg repository":
http://support.hglabhq.com/discussions/problems/76-does-not-appear-to-be-a-repository

Any idea of what can cause this or a possible solution?
Thanks! :)

My Output:

==START==

% hg clone --verbose https://URL/test "C:\temp\test"
http authorization required for https://URL/hg/test
realm: Hg Repo
 'https://URL/hg/test' does not appear to be an hg repository:
---%<--- (text/html; charset=utf-8)

<!DOCTYPE html>
<html>
<head>
  <meta charset="utf-8">
  <meta http-equiv="X-UA-Compatible" content="IE=Edge" />
  <title>Hg Repo</title>
  <link rel="shortcut icon" type="image/x-icon" href="/public/img/favicon/favicon.ico?v=1.10.6.0" />
  <link rel="apple-touch-icon" sizes="57x57" href="/public/img/favicon/apple-touch-icon-57x57.png">
  <link rel="apple-touch-icon" sizes="114x114" href="/public/img/favicon/apple-touch-icon-114x114.png">
  <link rel="apple-touch-icon" sizes="72x72" href="/public/img/favicon/apple-touch-icon-72x72.png">
  <link rel="apple-touch-icon" sizes="144x144" href="/public/img/favicon/apple-touch-icon-144x144.png">
  <link rel="apple-touch-icon" sizes="60x60" href="/public/img/favicon/apple-touch-icon-60x60.png">
  <link rel="apple-touch-icon" sizes="120x120" href="/public/img/favicon/apple-touch-icon-120x120.png">
  <link rel="apple-touch-icon" sizes="76x76" href="/public/img/favicon/apple-touch-icon-76x76.png">
  <link rel="apple-touch-icon" sizes="152x152" href="/
---%<---

[command returned code 255 Wed Jan 18 15:26:25 2017]

==END==

  1. Support Staff 1 Posted by Anton Gogolev on 19 Jan, 2017 06:35 AM

    Anton Gogolev's Avatar

    Hello, Jesper.

    Upgrading HgLab to 1.10.8 (this should be painless) will fix the issue:

    http://download.hglabhq.com/hglab/hglab-setup-1.10.8.exe

  2. 2 Posted by Jesper on 19 Jan, 2017 11:56 AM

    Jesper's Avatar

    Hello again.

    Thank you. This works with Mercurial 4.0.1 and TortoriseHg!

    Best regards,
    Jesper

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

18 Feb, 2019 09:20 AM
26 Nov, 2018 01:47 PM
16 Nov, 2018 07:51 PM
06 Nov, 2018 04:30 PM
24 Oct, 2018 07:57 AM

 

20 Jul, 2018 11:07 PM
05 Jul, 2018 10:53 AM
27 May, 2018 01:33 AM
14 May, 2018 03:38 PM
04 May, 2018 07:45 AM
28 Feb, 2018 07:08 AM