Pushing repo with sub repos results in 404

Gary's Avatar

Gary

25 Apr, 2017 04:40 PM

I've just set up a new install of HG Lab and run into a few problems.
I have a lot of existing repositories to push up to the server and some have worked ok, however I've found that if I attempt to push up a repo with a sub repo, I receive an error as follows:
abort: HTTP Error 404: Not found.

This error appears after the 'bundling' process has completed and about half way through the 'sending' process.
I'm not certain that the subrepositories are the cause of the issue, but I can't see any other difference between this an other repos that are working correctly.

In a separate issue, I've found that the system really doesn't like deleting repositories and projects - and then recreating them with the same name. ;)

  1. Support Staff 1 Posted by Anton Gogolev on 26 Apr, 2017 11:59 AM

    Anton Gogolev's Avatar

    Gary,

    Subrepositories in their "nested" flavour are currently not supported.

  2. 2 Posted by Gary Stanton on 02 May, 2017 08:22 AM

    Gary Stanton's Avatar

    Hi Anton,

    I have removed the sub-repository and commited the now empty '.hgsub' file
    - however the system is throwing the same error.

    Gary

  3. 3 Posted by Gary on 03 May, 2017 04:19 PM

    Gary's Avatar

    I have now attempted to push this repo, which no longer contains any reference to a sub repo, up to a completely different installation - new project, new repo.
    The sam error occurs. I'm not sure the issue is the sub repo - but I'm a little stuck.
    Can someone help?

  4. Support Staff 4 Posted by Anton Gogolev on 04 May, 2017 09:06 AM

    Anton Gogolev's Avatar

    Gary,

    Now this is weird. Can you do a "hg push --debug --verbose" and attach the
    output here?

  5. 5 Posted by Gary on 09 May, 2017 08:32 AM

    Gary's Avatar

    Hi Anton,

    The output is rather large, and doesn't give any extra info about the error, but perhaps it'll show you something:

    https://zerobin.net/?fba696c1d5d9676d#1Cb14mOCqC1yja7U+v71GFLiHD4AN/HGGC0P6wdbQ8g=

  6. Support Staff 6 Posted by Anton Gogolev on 11 May, 2017 09:23 AM

    Anton Gogolev's Avatar

    Gary,

    That turns out to be not just "404", but an IIS-specific variant thereof,
    "404.13 - Content Too Large" (
    https://support.microsoft.com/en-us/help/943891/the-http-status-code-in-iis-7.0,-iis-7.5,-and-iis-8.0)
    . Apparently, you have way too many binary files in your repository.

    To work around this, you can do incremental pushes as described here:
    https://hglabhq.com/blog/2014/6/20/working-with-mercurial-over-unreliable-connections
    . For example, this command will push two changesets at a time:

    hg push --rev "limit(sort(draft(), rev), 2)"

  7. 7 Posted by Gary on 15 May, 2017 08:50 AM

    Gary's Avatar

    Hi Anton,

    The repo contains about 2GB of images and unfortunately, a large majority of these were pushed in a single changeset.

    In case anyone else has the same problem:
    I resolved this issue by updating the content length allowed in the IIS settings for the site.
    Specifically increasing the maxrequestlength of the httpruntime settings and the maxAllowedContentLength in requestFiltering.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

18 Feb, 2019 09:20 AM
26 Nov, 2018 01:47 PM
16 Nov, 2018 07:51 PM
06 Nov, 2018 04:30 PM
24 Oct, 2018 07:57 AM

 

20 Jul, 2018 11:07 PM
05 Jul, 2018 10:53 AM
27 May, 2018 01:33 AM
14 May, 2018 03:38 PM
04 May, 2018 07:45 AM
28 Feb, 2018 07:08 AM