'This is not a valid source path' in Atlassian SourceTree

Taylor Meek's Avatar

Taylor Meek

21 Nov, 2013 02:28 AM

I'm using Atlassian SourceTree to connect to HgLab. I use it normally with my BitBucket account. I've set up HgLab on IIS 7 and can get to the console just fine. However, when I try to clone a repo using SourceTree, when I enter the Source Path / URL as HgLab provides it to me, I get this error message:
This is not a valid source path / URL
fatal: http://(munged)/hg/(project)/(repo)/info/refs not valid: is this a git repository?
abort: unknown revision 'tip'!

It seems not to be recognizing the repo as an Hg repo.

I'm able to use the hg.exe bundled with TortoiseHg to clone without issues.

  1. Support Staff 1 Posted by Anton Gogolev on 21 Nov, 2013 06:25 AM

    Anton Gogolev's Avatar

    Taylor,

    Where does /info/refs part come from? Could you please attach a screenshot with the error?

    Thanks in advance!

  2. 2 Posted by Meek, Taylor on 22 Nov, 2013 01:02 AM

    Meek, Taylor's Avatar

    I am not sure where it is coming up with /info/refs. It’s adding that to my source path that I’m providing. /info/refs seems to be a Git thing, which leads me to believe SourceTree is misidentifying HgLab as a Git host instead of an Hg host somehow.

  3. Support Staff 3 Posted by Anton Gogolev on 22 Nov, 2013 12:27 PM

    Anton Gogolev's Avatar

    Taylor,

    A wild guess: is Mercurial support enabled in SourceTree? Go to "Tools" -
    "Options" and click on "Mercurial" tab and check if everything is fine over
    there.

  4. 4 Posted by taylor.meek on 22 Nov, 2013 03:12 PM

    taylor.meek's Avatar

    Yep! I also uninstalled SourceTree and reinstalled it to try to only install the Mercurial bits and skip Git. I'll post a followup with my ST Mercurial config screen.

    -------- Original message --------

  5. Support Staff 5 Posted by Anton Gogolev on 25 Nov, 2013 06:54 AM

    Anton Gogolev's Avatar

    Taylor,

    How are things doing on your end?

  6. 6 Posted by tinh on 16 Dec, 2015 04:50 PM

    tinh's Avatar

    You must enable tool ->options ->git - > enable.
    if you have not git, you must dowload Git

  7. 7 Posted by Axel Landa on 30 Jul, 2019 08:59 PM

    Axel Landa's Avatar

    Primero que nada , valida si el sourcetree no te pide actualizaciones, probablemente tengas una actualizacion pendiente, una vez que lo actualices, te vas a tools/options/ luego en la pestaña de git le das en habilitar

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Sep, 2019 09:28 PM
21 Aug, 2019 09:07 AM
30 Jul, 2019 08:59 PM
31 May, 2019 02:29 PM
26 Nov, 2018 01:47 PM

 

16 Nov, 2018 07:51 PM
06 Nov, 2018 04:30 PM
24 Oct, 2018 07:57 AM
20 Jul, 2018 11:07 PM
05 Jul, 2018 10:53 AM
27 May, 2018 01:33 AM