When pushing files over some 20MB, I get "abort: error: An existing connection was forcibly closed by the remote host"

Stefan Vedeja's Avatar

Stefan Vedeja

21 Nov, 2013 12:12 PM

Smaller files works fine. I have added/changed the suggested sections in my web.config:


  1. Support Staff 1 Posted by Anton Gogolev on 21 Nov, 2013 12:16 PM

    Anton Gogolev's Avatar

    Stefan,

    Which settings specifically were you tweaking?

  2. 2 Posted by Vedeja Stefan on 21 Nov, 2013 12:26 PM

    Vedeja Stefan's Avatar

    Sorry, I was trying to add it to my original post. Here goes:

      <system.web>
                          <httpRuntime
                                                enableVersionHeader="false"
                                                executionTimeout="3600"
                                                maxRequestLength="536870912"
                                                maxUrlLength="8192"
                                                maxQueryStringLength="8192" />
      </system.web>
      <system.webServer>
        <security>
          <requestFiltering allowDoubleEscaping="true">
            <requestLimits maxQueryString="8192" maxAllowedContentLength="536870912" />
          </requestFiltering>
        </security>
      </system.webServer>

  3. Support Staff 3 Posted by Anton Gogolev on 21 Nov, 2013 12:34 PM

    Anton Gogolev's Avatar

    That's beyond strange.

    Could you please push with the following command and attach the push-debug-log.txt here:

    hg push --debug > push-debug-log.txt
    
  4. 4 Posted by Vedeja Stefan on 27 Nov, 2013 06:25 AM

    Vedeja Stefan's Avatar

    Here is my log.

  5. Support Staff 5 Posted by Anton Gogolev on 27 Nov, 2013 06:45 AM

    Anton Gogolev's Avatar

    Oh, it is HTTPS that you're using.

    There's a bug/problem in Python ( http://bugs.python.org/issue13885 ) and,
    as a consequence in Mercurial and TortoiseHG (
    http://bz.selenic.com/show_bug.cgi?id=3905 ,
    https://bitbucket.org/tortoisehg/thg/issue/2593/cant-push-over-30mb-to-iis-via-https)
    which results in this kind of behavior.

    There are really several options. You can either downgrade to Mercurial
    2.7.2, upgrade to Mercurial 2.8 or disable SSL altogether. Unfortunately,
    there's nothing I can do on my part.

  6. 6 Posted by Vedeja Stefan on 27 Nov, 2013 09:44 AM

    Vedeja Stefan's Avatar

    I’m experiencing the exact same with a fresh install of HgLab 1.0.1. Is that expected too?

  7. Support Staff 7 Posted by Anton Gogolev on 27 Nov, 2013 09:47 AM

    Anton Gogolev's Avatar

    Unfortunately, yes. This is purely client-side issue and has nothing to do
    with HgLab itself.

    The Internets say that you can disable SSLv2 in IIS (
    http://forums.iis.net/t/1151822.aspx ) and this _might_ help.

  8. 8 Posted by Vedeja Stefan on 27 Nov, 2013 10:14 AM

    Vedeja Stefan's Avatar

    Disabling SSLv2 to no avail.

    When you mention downgrading Python, do you mean client-side?

  9. Support Staff 9 Posted by Anton Gogolev on 27 Nov, 2013 10:18 AM

    Anton Gogolev's Avatar

    You don't need to downgrade Python per se (unless you're compiling
    Mercurial yourself); rather, you'll need to downgrade Mercurial itself.
    I've had reports of success with TortoiseHG 2.4.1 and Mercurial 2.2.2.

  10. 10 Posted by Vedeja Stefan on 27 Nov, 2013 10:48 AM

    Vedeja Stefan's Avatar
  11. Support Staff 11 Posted by Anton Gogolev on 27 Nov, 2013 10:50 AM

    Anton Gogolev's Avatar

    Mercurial 2.0 is way too old. Could you please try with 2.8?

  12. 12 Posted by Vedeja Stefan on 27 Nov, 2013 10:51 AM

    Vedeja Stefan's Avatar

    I had 2.8 installed originally.

  13. Support Staff 13 Posted by Anton Gogolev on 27 Nov, 2013 11:17 AM

    Anton Gogolev's Avatar

    That's unfortunate; apparently, this was not actually fixed in 2.8.

    Nevertheless, thanks a lot, Stefan!

  14. 14 Posted by Geoffroy on 27 May, 2016 08:39 PM

    Geoffroy's Avatar

    Hi

    I'm experimenting this issue with TortoiseHg 3.1 and Python 2.7.6. This post is old and I would like to know if the problem is still present with current version of HgLab. If this bug is known as fixed. What is the solution for this issue.

    Thank you

  15. Support Staff 15 Posted by Anton Gogolev on 30 May, 2016 09:01 AM

    Anton Gogolev's Avatar

    Hello, Geoffroy!

    Are you pushing over HTTPS?

  16. 16 Posted by Geoffroy on 30 May, 2016 12:12 PM

    Geoffroy's Avatar

    I think yes. I'm using this command

    hg push http://localhost/hglab/MyRepo

    Is it the best way to do things?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

18 Feb, 2019 09:20 AM
26 Nov, 2018 01:47 PM
16 Nov, 2018 07:51 PM
06 Nov, 2018 04:30 PM
24 Oct, 2018 07:57 AM

 

20 Jul, 2018 11:07 PM
05 Jul, 2018 10:53 AM
27 May, 2018 01:33 AM
14 May, 2018 03:38 PM
04 May, 2018 07:45 AM
28 Feb, 2018 07:08 AM