HgLab has no skinning

dave.nay's Avatar

dave.nay

13 May, 2013 04:21 PM

I must be missing some component on my new server. I have had HgLab set up on a test system for a month now, but today I am trying to install it on a production server. I seem to have everything working with the exception that HgLab looks terrible in the browser. It's all text, with no nice GUI (see attached file).

I'm sure there is just something missing from the server, but I don't know what...

Win Server 2008R2 x64, IIS7, HgLab 0.2.181, SQL Server Express 2008R2

  1. Support Staff 1 Posted by Anton Gogolev on 13 May, 2013 04:56 PM

    Anton Gogolev's Avatar

    Dave,

    What happens if you try to open /hglab/public/bootstrap/css/bootstrap.css in your browser?

  2. 2 Posted by dave.nay on 13 May, 2013 04:59 PM

    dave.nay's Avatar

    Hi Anton,

    I receive a 404 error: The requested resource(...) is not available.

    I have also been finding information regarding displaying CSS on IIS7, but I haven't found the solution yet.

    Dave

  3. Support Staff 3 Posted by Anton Gogolev on 13 May, 2013 05:06 PM

    Anton Gogolev's Avatar

    Dave,

    Just to double-check: your IIS installation does have "Static Content" feature enabled (Control Panel - Programs an Features - Turn Windows features on or off)?

  4. 4 Posted by dave.nay on 13 May, 2013 05:13 PM

    dave.nay's Avatar

    I believe it is yes. This is a Server 2008R2 system which I am a little unfamiliar with, but I believe this screen capture shows the static content feature being present.

  5. 5 Posted by dave.nay on 13 May, 2013 05:18 PM

    dave.nay's Avatar

    There seems to be something up with the Public folder?

    GET http://us16s-sw01/hglab/public/google-code-prettify/prettify.css 404 (Not Found) dashboard:11
    GET http://us16s-sw01/hglab/public/bootstrap/css/bootstrap.css 404 (Not Found) dashboard:11
    GET http://us16s-sw01/hglab/public/bootstrap/css/bootstrap-responsive.css 404 (Not Found) dashboard:11
    GET http://us16s-sw01/hglab/public/fontawesome/css/font-awesome.min.css 404 (Not Found) dashboard:11
    GET http://us16s-sw01/hglab/public/css/hglab.css 404 (Not Found) dashboard:11
    GET http://us16s-sw01/hglab/public/jquery/jquery-1.7.1.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/js/js.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/jquery.pjax/jquery.pjax.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/bootstrap/js/bootstrap.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/google-code-prettify/prettify.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/jquery.ui/jquery-ui-1.9.1.custom.min.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/jquery.timeago/jquery.timeago.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/js/ajax.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/bootbox/bootbox.min.js 404 (Not Found) dashboard:12
    GET http://us16s-sw01/hglab/public/jquery.peity/jquery.peity.min.js 404 (Not Found) dashboard:12
    Uncaught ReferenceError: jQuery is not defined dashboard:148

    (Logged from Chrome browser console)

  6. Support Staff 6 Posted by Anton Gogolev on 13 May, 2013 05:21 PM

    Anton Gogolev's Avatar

    Dave,

    Are these files actually there?

  7. 7 Posted by dave.nay on 13 May, 2013 05:23 PM

    dave.nay's Avatar

    ;-) Yes.

  8. Support Staff 8 Posted by Anton Gogolev on 13 May, 2013 05:27 PM

    Anton Gogolev's Avatar

    That's strange. Could you please ensure that "Static Content" (see my previous comment) is enabled?

  9. 9 Posted by dave.nay on 13 May, 2013 05:29 PM

    dave.nay's Avatar

    Sorry...I thought I did reply regarding the static content. This is an Server 2008R2 system, so it is a little different from your screen capture, but I believe it is enabled.

  10. Support Staff 10 Posted by Anton Gogolev on 13 May, 2013 05:34 PM

    Anton Gogolev's Avatar

    Dave,

    Will it be possible to set up a TeamViewer session so that I could diagnose the problem? I'll be available in 3 hours today or tomorrow for the whole day.

  11. 11 Posted by dave.nay on 13 May, 2013 05:36 PM

    dave.nay's Avatar

    Sure, TeamViewer is possible...probably tomorrow. Just post a message to this thread when you are available, or shoot me a direct email.

  12. 12 Posted by dave.nay on 13 May, 2013 05:41 PM

    dave.nay's Avatar

    I think I figured it out....or at least a major clue.

    I am hosting multiple sites on this IIS, and I think the requests are being directed at one of the other sites. If I disable the other sites and the rewrite rules, everything works in HgLab.

    I will do a writeup later if I figure out how to host multiple sites (specifically TeamCity and HgLab at the same time)

    Dave

  13. Anton Gogolev closed this discussion on 14 May, 2013 03:12 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

03 Aug, 2022 01:49 PM
05 Jul, 2022 07:01 PM
28 Mar, 2022 04:42 PM
21 Jan, 2022 10:43 AM
20 Jan, 2022 10:45 AM

 

18 Jan, 2022 10:15 AM
19 Mar, 2021 06:13 PM
01 Mar, 2021 02:51 PM
01 Jan, 2021 02:19 AM
28 Aug, 2020 08:34 AM
23 Jun, 2020 08:29 AM