Can't push due due to access denied for existing repo

ymorinrivest's Avatar

ymorinrivest

12 Jun, 2013 07:02 AM

This work fine if i create a new repo from hglab

I tried to copy my repository .hg to hglab's repo folder ( following the guide) and nothing happened. I added a project with the same name, and I manage to get my repo in HgLab. Pulling works, but pushing doens't work with the following error :

HTTP Error: 500 (Access to the path '...\.hg\store\00changelog.i' is denied.)

I had the look at the folder's permission and one to ASP.NET v4.0 is missing. I tried to add it without any success.

  1. Support Staff 1 Posted by Anton Gogolev on 13 Jun, 2013 09:48 AM

    Anton Gogolev's Avatar

    Yeah, copying existing repositories over to HgLab can be messy due to NTFS permissons.

    Try running the following commands in the cmd.exe:

    icacls {hglab-home-directory} /t /remove:g iis_iusrs
    icacls {hglab-home-directory} /grant iis_iusrs:(OI)(CI)(F)
    
  2. Anton Gogolev closed this discussion on 22 Aug, 2013 08:01 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

03 Aug, 2022 01:49 PM
05 Jul, 2022 07:01 PM
28 Mar, 2022 04:42 PM
21 Jan, 2022 10:43 AM
20 Jan, 2022 10:45 AM

 

18 Jan, 2022 10:15 AM
19 Mar, 2021 06:13 PM
01 Mar, 2021 02:51 PM
01 Jan, 2021 02:19 AM
28 Aug, 2020 08:34 AM
23 Jun, 2020 08:29 AM