Can't clone repository

Alexander's Avatar

Alexander

19 Nov, 2012 03:37 PM

I can't clone my repository using the following command:
hg clone --rev default http://vm:8081/hg/project/trunk_default C:\repository

I get the error: abort: HTTP Error 500: Invalid length: 7

But this works fine: hg clone http://vm:8081/hg/project/trunk_default C:\repository

Anton, can you help me?

  1. Support Staff 1 Posted by Anton Gogolev on 19 Nov, 2012 03:46 PM

    Anton Gogolev's Avatar

    #close

    Hi!

    Yep, that's a bug in HgLab which will be fixed in the next release. Meanwhile, you can try cloning without the "--rev default" specifier.

  2. Anton Gogolev closed this discussion on 20 Nov, 2012 09:22 AM.

  3. Alexander re-opened this discussion on 20 Nov, 2012 09:48 AM

  4. 2 Posted by Alexander on 20 Nov, 2012 09:48 AM

    Alexander's Avatar

    That's bad. The command is used through our CI Hudson. I'm not sure I't possible to control how it uses hg.

  5. Support Staff 3 Posted by Anton Gogolev on 20 Nov, 2012 10:05 AM

    Anton Gogolev's Avatar

    Hello, Alexander!

    Try updating to HgLab 0.1.391. Your problem should be fixed now.

    Sorry for the inconvenience!

  6. Anton Gogolev closed this discussion on 20 Nov, 2012 10:05 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

03 Aug, 2022 01:49 PM
05 Jul, 2022 07:01 PM
28 Mar, 2022 04:42 PM
21 Jan, 2022 10:43 AM
20 Jan, 2022 10:45 AM

 

18 Jan, 2022 10:15 AM
19 Mar, 2021 06:13 PM
01 Mar, 2021 02:51 PM
01 Jan, 2021 02:19 AM
28 Aug, 2020 08:34 AM
23 Jun, 2020 08:29 AM