HTTP Error 500; Server cannot modify cookies after HTTP headers have been sent.

Dean's Avatar

Dean

13 Aug, 2013 04:09 PM

HgLab was working great for me until today. I tried to do a post and the client (SourceTree) gets this: HTTP Error 500: Object reference not set to an instance of an object.

I looked in event viewer on the server and found this:
    Exception type: HttpException
    Exception message: Server cannot modify cookies after HTTP headers have been sent.

Attached is the log file from HgLab

  1. Support Staff 1 Posted by Anton Gogolev on 14 Aug, 2013 09:04 AM

    Anton Gogolev's Avatar

    Dean,

    You're running HgLab 0.2.181 which is a rather old version. Won't you mind upgrading to 0.3.10?

  2. 2 Posted by Dean on 14 Aug, 2013 03:19 PM

    Dean's Avatar

    I upgraded and get the same error. Log file attached.

  3. Support Staff 3 Posted by Anton Gogolev on 14 Aug, 2013 03:34 PM

    Anton Gogolev's Avatar

    Dean,

    Thanks for updating. That's a strange issue you're experiencing, so please bear with me.

    First, on the server where HgLab is running and open up cmd.exe, cd to c:\inetpub\hglab_home\data\repositories\master\repos\PowerAgent758, run hg verify --verbose and post the output here.

    Next, there's a file named c:\inetpub\hglab_home\data\repositories\master\repos\PowerAgent758\.hg\requires -- post this one here too, please.

  4. 4 Posted by Dean on 15 Aug, 2013 01:31 PM

    Dean's Avatar

    Looks like there is an integrity problem. Could that be causing the error in HgLab?

    C:\inetpub\hglab_home\data\repositories\master\repos\PowerAgent758>hg verify --verbose
    repository uses revlog format 1
    checking changesets
    checking manifests
    crosschecking files in changesets and manifests
    checking files
     unit test data/jpowertap/Joule21/testNoStartGPS.tcx@321: 6a98374a25f5 in manifests not found
     unit test data/jpowertap/Joule21/testRideOverlap.csv@321: e58ab958ce3b in manifests not found
    2363 files, 341 changesets, 4039 total revisions
    2 integrity errors encountered!
    (first damaged changeset appears to be 321)

  5. Support Staff 5 Posted by Anton Gogolev on 15 Aug, 2013 01:44 PM

    Anton Gogolev's Avatar

    Dean,

    Integrity problem indeed. Were you previously pushing to this repository
    via HgLab?

  6. 6 Posted by Dean on 15 Aug, 2013 02:39 PM

    Dean's Avatar

    Yes. I use Source Tree as my client, but use the URL to hglab as the destination.

  7. Support Staff 7 Posted by Anton Gogolev on 15 Aug, 2013 02:53 PM

    Anton Gogolev's Avatar

    Could you please run "hg verify --verbose" on your local repository? If
    it's not corrupt, you delete the ".hg" directory from your server
    repository and copy your local ".hg" directory over to server.

  8. 8 Posted by Dean on 15 Aug, 2013 05:33 PM

    Dean's Avatar

    Thanks. That cleaned it up and I no longer get the error.

  9. Anton Gogolev closed this discussion on 19 Aug, 2013 07:28 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 Mar, 2021 06:13 PM
01 Mar, 2021 02:51 PM
01 Jan, 2021 02:19 AM
28 Aug, 2020 08:34 AM
23 Jun, 2020 08:29 AM

 

19 Dec, 2019 06:58 AM
21 Aug, 2019 09:07 AM
30 Jul, 2019 08:59 PM
31 May, 2019 02:29 PM
26 Nov, 2018 01:47 PM
16 Nov, 2018 07:51 PM