This is not the page you are looking for.

Timm's Avatar

Timm

13 Dec, 2013 05:33 PM

Hello,

downloaded tons of installers today (.net 2.0, 3,5, 4,0... sql server 2008... etc.) to fullfil the prerequirements on our Win2003-Server.
Finally got an sql-server up an running... created an website in iis6, switched it to use asp.net 4.x...

"Something" seems to work... but what now?

If i try to access "http://localhost/hglab" with the browser on the server a "This is not the page you are looking for."-page is displayed.
The website basedir points to C:\Programme\HgLab HQ\HgLab - is this correct?

There was no configuration except the connection-string druing setup - is this correct?

Any hints?

Regards,

Timm

18:11:22.3737 - Info - - octalforty.Structural.Framework.Web.MvcApplication - starting application
18:11:22.3894 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initializing service provider factory
18:11:22.3894 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initialized service provider factory
18:11:22.3894 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initializing middleware pipeline
18:11:22.4050 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initialized middleware pipeline
18:11:22.4050 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initializing service provider
18:11:22.4050 - Info - - octalforty.Structural.ComponentModel.ServiceProviderFactory - started building container
18:11:27.2801 - Info - - HgLab.Core.Configuration.Modules.PersistenceModule - building session factory
18:11:28.1551 - Info - - HgLab.Core.Configuration.Modules.PersistenceModule - built session factory
18:11:28.3113 - Info - - octalforty.Structural.ComponentModel.ServiceProviderFactory - finished building container
18:11:28.3113 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initialized service provider
18:11:28.3113 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initializing framework
18:11:28.3426 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initialized framework
18:11:28.3426 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initializing services
18:11:28.3895 - Info - - octalforty.Structural.ComponentModel.Jobs.JobRuntimeService - starting thread for job 'HgLab.Core.Jobs.RepostoryStatsRefreshJob'
18:11:28.3895 - Info - - octalforty.Structural.ComponentModel.Jobs.JobRuntimeService - started thread for job 'HgLab.Core.Jobs.RepostoryStatsRefreshJob'
18:11:28.3895 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initialized services
18:11:28.3895 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initializing routes
18:11:28.3895 - Info - - octalforty.Structural.ComponentModel.Jobs.JobRuntimeService - started executing thread for job 'HgLab.Core.Jobs.RepostoryStatsRefreshJob'
18:11:28.4676 - Info - - octalforty.Structural.Framework.Web.MvcApplication - initialized routes
18:11:28.4676 - Info - - octalforty.Structural.Framework.Web.MvcApplication - started application

  1. Support Staff 1 Posted by Anton Gogolev on 13 Dec, 2013 09:19 PM

    Anton Gogolev's Avatar

    Timm,

    Installer asks for three pieces of information: Installation Directory, Home Directory and Connection String. If it didn't prompt for these then there's something fishy going on.

    HgLab itself required .NET 4.0 (or 4.5 for x64 systems) only, but all .NET Framework versions live happliy side-by-side, so this shouldn't be a problem.

    Getting HgLab to run on IIS 6.0 is a bit tricky. Things to check:

    1. Ensure that .NET 4.0 is indeed registered in IIS (aspnet_regiis -ir)
    2. Ensure that ASP.NET 4.0 is enabled in Web Server Extensions.
    3. The website that runs HgLab should be configured to use an AppPool with ASP.NET 4.0
    4. Wildcard mappings must be in place as well
    5. Authentication mode must be set to "None" in Web.config
    6. Anonymous authentication should be installed and enabled in IIS

    Additionallly, I can offer a TeamViewer session so that I could help you out.

    On 13.12.2013, at 21:35, "Timm" <[email blocked]> wrote:

  2. 2 Posted by Timm on 14 Dec, 2013 10:30 AM

    Timm's Avatar

    Hi Anton,

    installer asked for the all three pieces of information:
    Installdir is: C:\Programme\HgLab HQ\ (contains subdir HgLab with Web.config and much more stuff)
    Homedir is: D:\HgLab Home (contains only a subdir logs)
    ConnectionString is: top-secret g

    1. Ensure that .NET 4.0 is indeed registered in IIS (aspnet_regiis -ir)

    Had done this already... but lets do it one more time. ;-)

    C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis -ir
    Start installing ASP.NET (4.0.30319) without changing existing web applications to use this version of ASP.Net.
    ................. Finished installing ASP.NET (4.0.30319) without changing existing web applications to use this version of ASP.Net.

    1. Ensure that ASP.NET 4.0 is enabled in Web Server Extensions.

    Checked.

    1. The website that runs HgLab should be configured to use an AppPool with ASP.NET 4.0

    As HgLab is the only website on this machine, it uses the DefaultAppPool, which is activated. ASP.net 4.0.30319 is selected.

    1. Wildcard mappings must be in place as well

    Don't know what to do or check here...

    1. Authentication mode must be set to "None" in Web.config

    Checked.

    1. Anonymous authentication should be installed and enabled in IIS

    Checked.

    Any hints, what to do to check point 4 are welcome.

    Regards,

    Timm

  3. Support Staff 3 Posted by Anton Gogolev on 14 Dec, 2013 04:51 PM

    Anton Gogolev's Avatar

    Timm,

    Just a wild guess: what happens if you go directly to http://localhost/ ?

    On 14.12.2013, at 14:30, "Timm" <[email blocked]> wrote:

  4. 4 Posted by Timm on 15 Dec, 2013 12:18 PM

    Timm's Avatar

    Args...

    this works now... earlier there was a point, when it doesn't work. At that point there was the "ressource not available-page" from the browser...
    I removed the "Standardsite", that pointed to an non existing directory of an old app...

    Original question is answered now... HgLab seems to work now (could login, create first testproject...)

    Question is now:
    How do i move HgLab from host/* to host/hglab/ ?

    Regards

    Timm

  5. Support Staff 5 Posted by Anton Gogolev on 16 Dec, 2013 07:31 AM

    Anton Gogolev's Avatar

    Timm,

    IIS distinguishes a "Web Site" and a "Web Application". The former is what allows IIS to "listen" to a particular hostname and serve everything from the root (think http://foo.example.com). The latter is effectively a "subdirectory" inside a Web Site (the bar part in http://foo.example.com/bar).

    In order to do what you want, you'll need to create a Web Site (or reuse an existing one) with its Binding set to "localhost" (or just empty), and then create a Web Application inside the Web Site.

    There are couple links at the bottom of the Installing HgLab page and I can offer a helping hand with this over a TeamViewer.

  6. 6 Posted by Timm Kautz on 16 Dec, 2013 10:10 AM

    Timm Kautz's Avatar

    Thank you for your help.

     

    I will leave the website as is druing the trial. If we decide to buy HgLab later, i may try to move the site were it belongs… ;-)

     

    Your website says „It’s a breeze to install…“ – from the view of somebody who is not using SQL Server Express normally nor IIS-Web-Applications i can’t follow this statement… For me more detailed install instruction would have been helpful.

     

    At the end i got it up and running, but i had to google (and download) a lot.

     

    Regards,

     

    Timm

     

     

    Von: Anton Gogolev [mailto:[email blocked]]
    Gesendet: Montag, 16. Dezember 2013 08:32
    An: [email blocked]
    Betreff: Re: This is not the page you are looking for. [Problems #408]

  7. Support Staff 7 Posted by Anton Gogolev on 16 Dec, 2013 10:18 AM

    Anton Gogolev's Avatar

    Timm,

    Compared to what it takes to get HgWeb up and running on IIS/Apache,
    integrate it with ActiveDirectory and set up email notifications - HgLab is
    worlds simpler. But installation instructions definitely need more work,
    thanks for pointing this out!

  8. 8 Posted by Timm Kautz on 16 Dec, 2013 10:50 AM

    Timm Kautz's Avatar

    Sorry for bothering you again…

     

    Two things:

     

    1. Issue: Repo-Names with dots don’t work… „ABC.Testname“.

    Repodir is created as expected – but it isn’t accessible via website.

     

    2. Problem: Can’t view any commited file in browser if i browse the source via „Source“… default 404 from iis is shown.

    Url looks like this: http://10.30.1.1/projects/testproject/repositories/NochEinTest/source/files/4beb0130f683/EinWinFormsProg/Main.Designer.pas

                    (if i browse the changeset, there is code shown…)

     

     

    Von: Anton Gogolev [mailto:[email blocked]]
    Gesendet: Montag, 16. Dezember 2013 11:18
    An: [email blocked]
    Betreff: Re: This is not the page you are looking for. [Problems #408]

  9. Support Staff 9 Posted by Anton Gogolev on 16 Dec, 2013 11:03 AM

    Anton Gogolev's Avatar

    Timm,

    No worries - I'm here to help you :)

    All these errors are side-effects of using IIS 6.0. Try these steps:

    1. Right-click on your Web Application node in IIS and select "Properties"
    2. Open "Virtual Directory" tab and click "Configuration..."
    3. The "Wildcard application maps" list should be empty. Click "Insert..."
    4. Enter c:\windows\microsoft.net\framework\v4.0.30319\aspnet_isapi.dll into "Executable" textbox and uncheck the "Verify that file exists" checkbox
    5. "OK" all dialogs and try navigating your HgLab installation once more

    See the attached screenshot for an illustration.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

28 Mar, 2022 04:42 PM
21 Jan, 2022 10:43 AM
20 Jan, 2022 10:45 AM
18 Jan, 2022 10:15 AM
19 Mar, 2021 06:13 PM

 

01 Mar, 2021 02:51 PM
01 Jan, 2021 02:19 AM
28 Aug, 2020 08:34 AM
23 Jun, 2020 08:29 AM
19 Dec, 2019 06:58 AM
21 Aug, 2019 09:07 AM