Problem with installing hglab-1.1.0.msi

Moti's Avatar

Moti

10 Feb, 2014 09:13 AM

Hi,

Downloaded current version - hglab-1.1.0.msi.

Installed on windows server 2008 R2 machine.

Installing finished successfully (as reported by the MSI), but nothing changed. I have no new tables in the DB, i have nothing new in the IIS, and C:\HgLab Home is empty.

Also, could not find installation logs.

Where to look?

  1. Support Staff 1 Posted by Anton Gogolev on 10 Feb, 2014 09:40 AM

    Anton Gogolev's Avatar

    Hello!

    Running MSI gets you halfway there. Next you'll need to go to the IIS Management snap-in and create either a Web Site or a Web Application that will actually be serving HgLab.

    The reason it's not done in the installer is because that would effectively mean duplicating all the functionality of IIS Management console, in an inferior way.

    As for database and Home Directory - these will be configured automatically as soon as you open up HgLab in the browser and configure it for the first time.

    Hope that helps. In case it doesn't, please do contact me.

    On 10.02.2014, at 13:14, "Moti" <[email blocked]> wrote:

  2. 2 Posted by Moti on 10 Feb, 2014 09:45 AM

    Moti's Avatar

    Quick response! Thanks.

    It might be a good idea to add the path where the hglab installer creates the files (mine is C:\Program Files (x86)\HgLab HQ\HgLab).

    I have created a new web site (port 81) under asp.net 4.0 integrated application pool, and receiving 404 where surfing to: : http://localhost:81/dashboard.

    Anything else needs to be done?

  3. Support Staff 3 Posted by Anton Gogolev on 10 Feb, 2014 10:00 AM

    Anton Gogolev's Avatar

    That should be it.

    Is there anything fishy under c:\hglab home\logs\ ?

    On 10.02.2014, at 13:46, "Moti" <[email blocked]> wrote:

  4. 4 Posted by Moti on 10 Feb, 2014 10:54 AM

    Moti's Avatar

    yep. bad connection string.

    Thanks.

    Is there anyway i can contribute to the documentation of the installation process? do you accept pull requests?

  5. Support Staff 5 Posted by Anton Gogolev on 10 Feb, 2014 10:59 AM

    Anton Gogolev's Avatar

    That's strange: connection string is validated during installation and you
    are not allowed to continue until installer successfully connects to the
    SQL Server.

    Unfortunately, for the time being I cannot accept pull requests due to
    various legal and licensing issues. But thanks for offering help. I know
    that documentation is lacking and I'm actively working on that.

    So you're up and running?

  6. 6 Posted by Moti on 10 Feb, 2014 06:53 PM

    Moti's Avatar

    Yes, up and running for now. Thanks for your help.

    Regarding the connection string, i think what happened is that when i could not find what i was looking for i did a repair using the msi and i overrun the connection string.

    As for the legal issues i think it will be worth it to sort it out. If Microsoft accept contributions so can you :). Be glad to help with this project if possible,.

  7. Anton Gogolev closed this discussion on 24 Feb, 2014 02:54 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

03 Aug, 2022 01:49 PM
05 Jul, 2022 07:01 PM
28 Mar, 2022 04:42 PM
21 Jan, 2022 10:43 AM
20 Jan, 2022 10:45 AM

 

18 Jan, 2022 10:15 AM
19 Mar, 2021 06:13 PM
01 Mar, 2021 02:51 PM
01 Jan, 2021 02:19 AM
28 Aug, 2020 08:34 AM
23 Jun, 2020 08:29 AM