Unable to clone

craig's Avatar

craig

27 Mar, 2015 01:44 AM

I have been able to successfully convert a Git repo to Mercurial and then push it to HgLab. Additional pushes to keep it in sync with Git while we evaluate Mercurial are working fine. We are unable, however, to clone the repo. Any attempts to do so are met with the error message that the URL is not an Hg repository. If I try to access the URL in my browser it pulls up the same page that I get if I click on the "Cloning Instructions" link for my repo. If I run clone with the --debug statement, I get the following:

>hg clone --debug http://10.1.1.159:88/hg/windev/windows WindowsHg
using http://10.1.1.159:88/hg/windev/windows
sending capabilities command
using auth.hglab.* for authentication
http auth: user craig, password **********
sending branchmap command
sending stream_out command
real URL is http://10.1.1.159:88/error?aspxerrorpath=/hg/windev/windows
requested URL: 'http://10.1.1.159:88/hg/windev/windows?cmd=stream_out'
abort: 'http://10.1.1.159:88/error?aspxerrorpath=/hg/windev/windows' does not appear to be an hg repository:
---%<--- (text/html; charset=utf-8)
<!DOCTYPE html>
<html>
<head>
  <meta charset="utf-8">
  <meta http-equiv="X-UA-Compatible" content="IE=Edge" />
  <title>HgLab Error</title>
  <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />

  <meta name="viewport" content="width=device-width, initial-scale=1.0">

  <link rel="stylesheet" href="/public/bootstrap/css/bootstrap.css"/><link rel="stylesheet" href="/public/bootstrap/css/
bootstrap-responsive.css"/><link rel="stylesheet" href="/public/google-code-prettify/prettify.css"/><link rel="styleshee
t" href="/public/css/hglab.css"/><link rel="stylesheet" href="/public/fontawesome/css/font-awesome.min.css"/><link rel="
stylesheet" href="/public/nvd3/nv.d3.css"/>
  <script src="/public/jquery/jquery-1.7.1.js" type="text/javascript"></script><script src="/public/jquery.ui/jquery-ui-
1.9.1.custom.min.js" type="text/javascript"></script><script src="/public/jquery.pjax/jquery.pjax.js" type="text/javascr
ipt"></script><script src="/public/bootstrap/js/bootstrap.js" type="text/java
---%<---
!

  1. Support Staff 1 Posted by Anton Gogolev on 27 Mar, 2015 06:35 AM

    Anton Gogolev's Avatar

    Craig,

    There appears to be a problem with "LAN Optimizations", so disabling it should help ( https://hglabhq.com/documentation/administrator-guide/repositories ). But before that, could you please see what the logs say (again, HGLAB-HOME\logs)?

  2. 2 Posted by craig on 27 Mar, 2015 05:28 PM

    craig's Avatar

    I ended up disabling LAN Optimizations between the time I posted the
    issue and the time I got your email, and that did indeed allow me to
    clone. Unfortunately, I have yet to get a clone that is not corrupt,
    which may be related to the web interface exception I posted about
    separately.

    Craig

  3. Anton Gogolev closed this discussion on 03 May, 2015 01:00 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

03 Aug, 2022 01:49 PM
05 Jul, 2022 07:01 PM
28 Mar, 2022 04:42 PM
21 Jan, 2022 10:43 AM
20 Jan, 2022 10:45 AM

 

18 Jan, 2022 10:15 AM
19 Mar, 2021 06:13 PM
01 Mar, 2021 02:51 PM
01 Jan, 2021 02:19 AM
28 Aug, 2020 08:34 AM
23 Jun, 2020 08:29 AM